centos 7 环境下成功安装 swoole的扩展
2019.08

一、升级php版本

使用yum自动安装的php版本比较旧,一般都是PHP5.3.3这个版本,很多php扩展功能都不被支持。所以我们有的时候有必要升级一下php版本。

1  如果已经安装PHP5.3.3版本的,需要先卸载干净

1)yum remove php* php-common

2)php-v查看php是否卸载干净

2、默认的yum源无法升级PHP,需要添加第三方yum源,我们选择webtatic库

CentOs 7.X

rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
 

3、正式安装php7.2:

1、查看yum是否有php7.2安装包

yum list php72

2、安装php以及相关插件

yum install php72w php72w-opcache  php72w-xml  php72w-mcrypt   php72w-gd php72w-devel php72w-mysqlnd  php72w-intl    php72w-mbstring   php72w-pear  php72w-pdo  php72w-fpm
 
 4、查看当前php版本

php -v

二、安装swool扩展

1、下载安装包(官网最新包是4.0 下载相对应的就行)

$ sudo wget https://github.com/swoole/swoole-src/archive/v2.0.6.tar.gz
$ sudo tar zxvf swoole-src-2.0.6.tar.gz
$ cd swoole-src-2.0.6
2、 编译安装

phpize (ubuntu 没有安装phpize可执行命令:sudo apt-get install php-dev来安装phpize)
./configure
make 
sudo make install
注:1、phpize是用来安装php的扩展的,应下载相对应php版本的 php-devel(yum install php70w-devel)

2、configure: error: in `/wwwroot/swoole-4.2.5':
configure: error: C++ preprocessor "/lib/cpp" fails sanity check

解决:yum install glibc-headers
yum install gcc-c++ 

 

三、修改php.ini文件

1、vi /usr/local/php/etc/php.ini   底部添加 

extension=swoole.so

2、重启php-fpm service php-fpm restart

3、查看扩展:php -m (你会看到扩展中多了一个swoole)

Share